[Rubygems-developers] Help with Gem Dependencies

Bret Pettichord bret at pettichord.com
Tue Jun 3 23:17:53 EDT 2008


That's useful information

>gem -v
0.9.2

Because of some bugs in Ruby 1.8.6, we are still using Ruby 1.8.5.
Haven't looked at 1.8.7 yet. I'll look into your suggestion further...

Bret



On Tue, Jun 3, 2008 at 10:02 PM, Gordon Thiesfeld <gthiesfeld at gmail.com> wrote:
> On Tue, Jun 3, 2008 at 8:30 PM, Bret Pettichord <bret at pettichord.com> wrote:
>>
>> Appreciate any help or insight you can provide.
>
> I'm more of a lurker than an authority on this list, but it appears
> you have an older version of rubygems installed.  RubyGems prior to
> 1.0 or thereabouts would prompt the user for which version of the gem
> to install.  Newer versions will do the right thing, and install the
> correct gem.
>
> To check this which version you have installed, you would run
>
> C:\ruby>gem -v
> 1.1.1
>
> If it's older than 1.1.1, I would recommend updating.
>
> C:\ruby>gem update --system
> Updating RubyGems
>
> Hope that helps,
>
> Gordon
> _______________________________________________
> Rubygems-developers mailing list
> Rubygems-developers at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rubygems-developers
>



-- 
Bret Pettichord
CTO, WatirCraft LLC
Lead Developer, Watir, http://wtr.rubyforge.org
Blog (Essays), http://www.io.com/~wazmo/blog
MiniBlog (Links), http://feeds.feedburner.com/bretshotlist


More information about the Rubygems-developers mailing list