[Rubygems-developers] HEADSUP RubyGems 1.2 Real Soon Now

Donavan Pantke avatar at spellboundnet.com
Tue Jun 3 21:17:20 EDT 2008

On Tuesday 03 June 2008 08:28:18 pm John Barnette wrote:
> On Tue, Jun 3, 2008 at 4:36 PM, Eric Hodel <drbrain at segment7.net> wrote:
> > 1.2 now features dependency types for dependent gems thanks to John
> > Barnette.  Current types are :runtime and :development, but I believe I 
> > add :install (for passenger).
> When I committed, I couldn't remember the use case for :install, so
> Ryan and I removed it. Could you refresh my memory?

The :install flag is required for gems that have specific loading 
requirements, and so cannot have dependencies automatically activated. The 
biggest use case is Passenger, which can activate multiple versions of Rails. 
It originally required rails in the gemspec (as it needs some version of 
Rails), but that meant that when the passenger gem activated, rails 
automatically activated as well. That caused passenger to blow up when trying 
to activate a different version of Rails. Having the :install flag will allow 
Passenger to be loaded but let Passenger worry about Rails.

> ~ j.
> _______________________________________________
> Rubygems-developers mailing list
> Rubygems-developers at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rubygems-developers

More information about the Rubygems-developers mailing list