[Rubygems-developers] gem dependencies not working in rubygems 1.2.0 on MacOS 10.5.3

Stephen Bannasch stephen.bannasch at deanbrook.org
Thu Jul 3 16:47:40 EDT 2008

At 12:13 PM -0700 7/3/08, Chad Woolley wrote:
>On Thu, Jul 3, 2008 at 6:26 AM, Stephen Bannasch
><stephen.bannasch at deanbrook.org> wrote:
>> I've got rubygems 1.2.0 installed on MacOS 10.5.3 and when I tried to
>> install sake it failed because I didn't have the proper ParseTree and
>> ruby2ruby gems installed.
>> Bug report submitted:
> > http://rubyforge.org/tracker/index.php?func=detail&aid=21056&group_id=126&atid=575
>Try running the same scenario, but with all commands (env, dependency)
>run as sudo.  You are probably picking up a different env/rubygems
>version in your root environment.  Not saying it is not a problem, but
>we should see exactly what the env is for root to see why the sudo'd
>installation is failing.

Hi Chad, I updated the bug report with the tests you requested:


Still the same problem.

I also then tried installing gems into another ruby (ruby_1_8 head) that doesn't need sudo.

Same problem ... but a new realization.

uuidtools installed (no dependency)
rails installed (a number of dependencies)

sake didn't (dependencies listed, but not acted on)

Perhaps there is a way the dependencies are defined in sake (and perhaps other gems) that used to work and stopped working with 1.2.0.

More information about the Rubygems-developers mailing list