[Rubygems-developers] gem update --system with a version requirement?

Chad Woolley thewoolleyman at gmail.com
Sat Jan 5 22:08:42 EST 2008

On Jan 5, 2008 2:33 AM, Eric Hodel <drbrain at segment7.net> wrote:
> If you have multiple rubygems updates installed, you can choose which
> one to install with:
> update_rubygems _0.9.4_

OK, this works for my purposes.  One problem, though.  It always
appears to install the latest installed update version, regardless of
the parameter that is passed.  Strangely, it seemed to work when I did
the same thing via irb (explicitly run "gem 'rubygems-update',
'1.0.0', then "load 'update_rubygems'").

I opened a bug for this:


More information about the Rubygems-developers mailing list