[Rubygems-developers] gem update --system with a version requirement?

Eric Hodel drbrain at segment7.net
Sat Jan 5 04:33:01 EST 2008


On Jan 3, 2008, at 14:31 PM, Jim Weirich wrote:
> On Jan 3, 2008, at 4:07 PM, Chad Woolley wrote:
>
>> Is there any way to do a gem update --system, but only to a specified
>> version?  I'd like to automate my gem system updates, but only up  
>> to a
>> version that I have tested, like = 1.0.1.
>
> You should be able to do a
>
>    gem install rubygems-update -v1.0.1
>
> and run the update_rubygems script manually (warning: from memory and
> untested)
>
> It's two steps, but it is under your control then.

If you have multiple rubygems updates installed, you can choose which  
one to install with:

update_rubygems _0.9.4_


More information about the Rubygems-developers mailing list