[Rubygems-developers] warnings from open-uri

Chad Woolley thewoolleyman at gmail.com
Fri Feb 1 18:48:46 EST 2008

On Feb 1, 2008 12:04 PM, Berger, Daniel <Daniel.Berger at qwest.com> wrote:
> Upon further review, it looks like we include the open-uri.rb from 1.9
> because the 1.8.5 (1.8.x?) version
> does not support user/password on authenticating proxies. That's what
> Jim Weirich's comment says anyway.
> I can only guess that you are explicitly require'ing open-uri.rb at some
> point in your test suite Chad. Then, when you require rubygems, it loads
> the 1.9 version, and you end up with the warnings.

You mean I am requiring the old 1.8.5 open-uri first, rather than the
1.9 version from rubygems?  I'll look into that.

I'm not explicitly requiring open-uri, but I am requiring some files
explicitly out of RubyGems, as part of GemInstaller (which
programatically calls the RubyGems API).  I guess I may be doing
something in the wrong order.

This points me in the right direction, though.  Thanks.

-- Chad

> I'm not sure what the solution is for you other than, "Don't do that".

More information about the Rubygems-developers mailing list