[Rubygems-developers] help rmagick error on gem install

anmol anmolanand at gmail.com
Wed Dec 31 08:09:49 EST 2008

Thanks Luis Lavena and Eric Hodel for giving me prompt replies.

I tried solutions given by both you.I went to
and followed the steps there and after complete installation I did :

anmol at anmol-laptop:~/Desktop/rubygems-1.3.1$ gem -v
/usr/local/lib/site_ruby/1.8/rubygems.rb:274:in `initialize': wrong
number of arguments (1 for 0) (ArgumentError)
	from /usr/local/lib/site_ruby/1.8/rubygems.rb:274:in `new'
	from /usr/local/lib/site_ruby/1.8/rubygems.rb:274:in `configuration'
	from /usr/local/lib/site_ruby/1.8/rubygems.rb:520:in `path'
	from /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:66:in
	from /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:56:in
	from /usr/local/lib/site_ruby/1.8/rubygems.rb:736:in `source_index'
	from /usr/local/lib/site_ruby/1.8/rubygems/gem_path_searcher.rb:86:in
	from /usr/local/lib/site_ruby/1.8/rubygems/gem_path_searcher.rb:21:in
	 ... 6 levels...
	from /usr/local/lib/site_ruby/1.8/rubygems/gem_runner.rb:8:in
	from /usr/local/lib/site_ruby/1.8/rubygems/gem_runner.rb:8
	from /usr/bin/gem:10:in `require'
	from /usr/bin/gem:10

after this I removed rubygems from /usr/local/lib/site_ruby/1.8 and
then reinstalled with help of tarball but the same thing happened when
I did 'gem -v'.

I am using Ubuntu 8.04.

Please suggest some solution.


On Dec 31, 9:20 am, Eric Hodel <drbr... at segment7.net> wrote:
> On Dec 30, 2008, at 19:50 PM, anmol wrote:
> > and when I tried the 'gem' command, the output is as follows:
> > anmol at anmol-laptop:~/skid1/skid$ gem install -v=2.1.0 rails
> > /usr/local/lib/site_ruby/1.8/rubygems.rb:274:in `initialize': wrong  
> > number of arguments (1 for 0) (ArgumentError)
> In RubyGems 1.3.1 this line is:
> $ cat -n REL_1_3_1/lib/rubygems.rb | grep 274
>     274     @configuration ||= Gem::ConfigFile.new []
> Likely this is the version you have (partially) installed.
> Gem::ConfigFile.new has taken one argument all the way back to 1.3.1.  
> I suspect you have a corrupted or edited install.  Please try removing  
> RubyGems from /usr/local/lib/site_ruby/1.8 and reinstalling from the  
> tarball.  You may need to remove RubyGems versions installed via  
> package as well.
> _______________________________________________
> Rubygems-developers mailing list
> Rubygems-develop... at rubyforge.orghttp://rubyforge.org/mailman/listinfo/rubygems-developers

More information about the Rubygems-developers mailing list