[Rubygems-developers] help rmagick error on gem install

Eric Hodel drbrain at segment7.net
Tue Dec 30 23:20:32 EST 2008


On Dec 30, 2008, at 19:50 PM, anmol wrote:

> and when I tried the 'gem' command, the output is as follows:
>
> anmol at anmol-laptop:~/skid1/skid$ gem install -v=2.1.0 rails
> /usr/local/lib/site_ruby/1.8/rubygems.rb:274:in `initialize': wrong  
> number of arguments (1 for 0) (ArgumentError)

In RubyGems 1.3.1 this line is:

$ cat -n REL_1_3_1/lib/rubygems.rb | grep 274
    274	    @configuration ||= Gem::ConfigFile.new []

Likely this is the version you have (partially) installed.

Gem::ConfigFile.new has taken one argument all the way back to 1.3.1.   
I suspect you have a corrupted or edited install.  Please try removing  
RubyGems from /usr/local/lib/site_ruby/1.8 and reinstalling from the  
tarball.  You may need to remove RubyGems versions installed via  
package as well.


More information about the Rubygems-developers mailing list