[Rubygems-developers] help rmagick error on gem install

Anmol Anand anmolanand at gmail.com
Mon Dec 29 10:24:46 EST 2008

I Had sent this mail to "rubygems-developers at rubyforge.org" without using
'help' in subject and I apologise for my mistake . Please pardon me, below I
describe my problem.

I have been trying to install Rmagick but have been
unsuccessful.People on Rmagick forum told me that the error is a ruby
gem error, Please help!!!
When I typed the command "sudo gem install rmagick", I got the following error::

anmol at anmol-laptop:~$ sudo gem install rmagick

/usr/local/lib/site_ruby/1.8/rubygems.rb:274:in `initialize': wrong
number of arguments (1 for 0) (ArgumentError)
from /usr/local/lib/site_ruby/1.8/rubygems.rb:274:in `new'

from /usr/local/lib/site_ruby/1.8/rubygems.rb:274:in `configuration'
from /usr/local/lib/site_ruby/1.8/rubygems.rb:520:in `path'
from /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:66:in

from /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:56:in
from /usr/local/lib/site_ruby/1.8/rubygems.rb:736:in `source_index'
from /usr/local/lib/site_ruby/1.8/rubygems/gem_path_searcher.rb:86:in

from /usr/local/lib/site_ruby/1.8/rubygems/gem_path_searcher.rb:21:in
... 6 levels...
from /usr/local/lib/site_ruby/1.8/rubygems/gem_runner.rb:8:in `require'
from /usr/local/lib/site_ruby/1.8/rubygems/gem_runner.rb:8

from /usr/bin/gem:10:in `require'
from /usr/bin/gem:10

Please help!!!
Thanks in advance.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rubygems-developers/attachments/20081229/70ef4d2c/attachment.html>

More information about the Rubygems-developers mailing list