[Rubygems-developers] Why is spec.autorequire deprecated?

Caspar Florian Ebeling florian.ebeling at gmail.com
Wed Aug 27 07:35:14 EDT 2008


I'm just writing a gem spec and I got a warning about
Specification#autorequire being deprecated. Maybe I
miss an important part, but isn't that the idea, to first
require "rubygems" (if ruby 1.8), then the gem, and then
be able to access classes etc? How is it meant to work
otherwise?

Florian

-- 
Florian Ebeling
florian.ebeling at gmail.com


More information about the Rubygems-developers mailing list