[Rubygems-developers] problems with 1.3.0 non-root autoinstall

Martin Krauskopf martin.krauskopf at gmail.com
Thu Aug 21 16:12:17 EDT 2008

Chad Woolley wrote:
> However, even 1.2.0.rev is not correct.  It should really be 1.3.0.rev

If next stable release is supposed to be 1.3.0 then trunk can't be 
1.3.0.dev. It must be >1.2.0 & <1.3.0. So 1.2.0.rev seems to be more 
correct then 1.3.0.dev.

> (in other words, bumped immediately after release).  Otherwise, apps
> which call the API and need to perform version-specific logic
> branching still cannot tell the difference between 1.2 and 1.3 when
> running against trunk.

Such apps should not make such assumption, I think. Since trunk might 
become e.g. 2.0. So they should rather based the logic on the released 
version vs. the '>latest_stable_release' version, i.e. trunk. So current 
1.2.0.rev works well.


More information about the Rubygems-developers mailing list