[Rubygems-developers] Gem binary clash problems.

Neil Wilson neil at brightbox.co.uk
Sat Aug 16 02:40:14 EDT 2008


2008/8/13 Eric Hodel <drbrain at segment7.net>:
> --format-executables is provided for this purpose, but it is a rare need.
>  Most users of RubyGems have only one ruby installed.

At the moment perhaps. However once 1.9 goes production ready I expect
a lot of people wanting to swap and change around.


> I think making a few changes to when RubyGems overwrites executables will
> help a lot, primarily by asking the user about what to do, and advertising
> about --format-executables at that time.

Be careful when asking for input. It makes gems much harder to script.


--
Neil Wilson


More information about the Rubygems-developers mailing list