[Rubygems-developers] Ruby1.9 and Edge Gems - gem_prelude error.

Eric Hodel drbrain at segment7.net
Wed Aug 13 18:33:59 EDT 2008


On Aug 5, 2008, at 01:31 AM, Neil Wilson wrote:

> I have the latest committed version of gem installed along with
> Ruby1.9. I can install gems with gem1.9 however when I try and run a
> binary (such as 'cap' from Capistrano) I get.
>
> gem_prelude.rb:113:in `push_gem_version_on_load_path': undefined
> method `<=>' for nil:NilClass (NoMethodError)
>       from gem_prelude.rb:8:in `gem'
>       from /usr/local/bin/cap:18:in `<main>'
>
> Is anybody else seeing this?

Yes, I will fix it.


More information about the Rubygems-developers mailing list