[Rubygems-developers] Ruby1.9 and Edge Gems - gem_prelude error.

Neil Wilson neil at brightbox.co.uk
Tue Aug 5 04:31:29 EDT 2008

I have the latest committed version of gem installed along with
Ruby1.9. I can install gems with gem1.9 however when I try and run a
binary (such as 'cap' from Capistrano) I get.

gem_prelude.rb:113:in `push_gem_version_on_load_path': undefined
method `<=>' for nil:NilClass (NoMethodError)
       from gem_prelude.rb:8:in `gem'
       from /usr/local/bin/cap:18:in `<main>'

Is anybody else seeing this?

Neil Wilson

More information about the Rubygems-developers mailing list