[Rubygems-developers] Questions on 1.0.0 on JRuby

Luis Lavena luislavena at gmail.com
Mon Apr 7 18:52:57 EDT 2008


On Mon, Apr 7, 2008 at 7:19 PM, Eric Hodel <drbrain at segment7.net> wrote:
> On Apr 7, 2008, at 10:49 AM, Charles Oliver Nutter wrote:
>
>
>  >
>  > FWIW, I'm going to continue including a 'gem' script with JRuby
>  > releases
>  > no matter what, since that's the command everyone uses and I want it
>  > to
>  > work.
>
>  I'm willing to change the default in a future minor release (not
>  1.1.1), but primarily I think the problem is going to be user education.
>
>  Is there any particular reason why JRuby and Ruby can't use the same
>  gem repository?  (Currently Rubinius does not, but after reading this
>  thread, I think that may be a mistake).
>

I think the problem is related to RbConfig and where it supposed to
find gems on:

  - RUBY VERSION: 1.8.6 (2008-03-03 patchlevel 114) [i386-mswin32]
  - INSTALLATION DIRECTORY: C:/Ruby/lib/ruby/gems/1.8
  - RUBY EXECUTABLE: C:/Ruby/bin/ruby.exe
  - GEM PATHS:
    - C:/Ruby/lib/ruby/gems/1.8

===

  - RUBY VERSION: 1.8.6 (2008-03-28 patchlevel 6360) [java]
  - INSTALLATION DIRECTORY: C:/JRuby/lib/ruby/gems/1.8
  - RUBY EXECUTABLE: C:/JRuby/bin/jruby.bat.exe
  - GEM PATHS:
     - C:/JRuby/lib/ruby/gems/1.8

The thing is neither of Ruby implementation are aware of each other.

PS: bikeshed?

-- 
Luis Lavena
Multimedia systems
-
Human beings, who are almost unique in having the ability to learn from
the experience of others, are also remarkable for their apparent
disinclination to do so.
Douglas Adams


More information about the Rubygems-developers mailing list