[Rubygems-developers] Patch added.

Eric Hodel drbrain at segment7.net
Sun Sep 30 20:01:34 EDT 2007


On Sep 29, 2007, at 23:44 , Alan C Francis wrote:
> <config_file_hash_accessor_patch.diff>
>
> I've added
>
>     instance_variable_set("@#{key.to_sym}", value) if respond_to?  
> key.to_sym
>
> to Gem::ConfigFile # []=
>
> Which seems to work on the command line.  Unfortunately I can't  
> seem to run the tests so can't verify I haven't broken anything :-)

I decided to go the opposite way around, and use  
Gem.configuration.update_sources instead of the hash-type access.  It  
would probably be better to remove the hash access going forward,  
since it adds lots of complication and requires more manual  
documentation.

> ------
>
> Harpo:~/work/rubygems_trunk acf$ rake
> (in /Users/acf/work/rubygems_trunk)
> ./lib/rubygems/custom_require.rb:27:in `gem_original_require': ./ 
> lib/rubygems/digest/md5.rb:16: syntax error, unexpected '.',  
> expecting '\n' or ';' (SyntaxError)
>     def Gem::MD5.md5(string)
>                  ^

Fixed, I'm dumb.

--
Poor workers blame their tools. Good workers build better tools. The
best workers get their tools to do the work for them. -- Syndicate Wars




More information about the Rubygems-developers mailing list