[Rubygems-developers] Error with local install

Eric Hodel drbrain at segment7.net
Sat Sep 8 10:46:10 EDT 2007


On Sep 7, 2007, at 21:16, TRANS wrote:
> On 9/7/07, Jim Weirich <jim.weirich at gmail.com> wrote:
>> On Sep 7, 2007, at 10:13 PM, TRANS wrote:
>>> Exactly the same.
>>>
>>>   $ sudo gem install --backtrace facets-2.0.0.gem
>>>   ERROR:  Error installing gem facets-2.0.0.gem[.gem]: undefined
>>> method `required_ruby_version' for nil:NilClass
>>
>> My guess is that you installed a gem with the beta version of
>> RubyGems, then switched back to a previous version.
>
> I generated the gem, then tried to install it as a test and got this
> error. Then I upgraded to the latest version of RubyGems 0.9.4 and did
> it all again. Both times I got the exact same error. Here's the
> metadata as it exists in the gem:
>
> --- !ruby/object:Box::GemSpecification
> [...]
>
>> To fix:  (1) Uninstall the offending gem, or (2) grep the gem/
>> specification directory for require_ruby_version and delete that line
>> from the spec.
>
> I could delete require_ruby_version, if that would fix the problem,
> but since RubyGems is generating this spec, it really doesn't solve my
> problem beyond this one test install.

Box::GemSpecification is not generated by RubyGems.

--
Poor workers blame their tools. Good workers build better tools. The
best workers get their tools to do the work for them. -- Syndicate Wars




More information about the Rubygems-developers mailing list