[Rubygems-developers] Transitioning from 0.9.4 to 0.9.5

Tom Copeland tom at infoether.com
Mon Oct 29 21:58:31 EDT 2007


On Mon, 2007-10-29 at 21:53 -0300, Luis Lavena wrote:
> > Hm, is there some way we can tweak the gem index to skip these or
> > something?  Right now I've disabled gem index rebuilds to prevent
> > someone from releasing a gem and accidentally breaking the index for
> > everyone...
> >
> 
> Tom, it seems only happens when trying to install gems build for
> Gem::Platform::CURRENT, since Platform is now a Class instead of
> String with previous version.
> 
> To summarize, this only affects gems with platform like x86-mswin32-60
> or x86-mswin32-80, since all the ::RUBY platforms remains the same
> 
> (Evan Weaver confirmed this on #irc today when talking about it).

Hi Luis -

Ah, OK, cool, thanks for the info.

> If you put a gem with 0.9.4.6 specification, it brake the indexing
> process? I guess not.

Hm, that sounds right, although I haven't tried it.

> Also, Hiroshi proposed a patch [1] to workaround this issue from the 'gem' side.
> 
> Since I really don't know the exact setup where you create the index,
> could provide more info?

I just call GemIndexer::new.generate_index:

http://rubygems.rubyforge.org/svn/trunk/lib/rubygems/indexer.rb

Yours,

Tom




More information about the Rubygems-developers mailing list