[Rubygems-developers] Asking me for prerequisites

Berger, Daniel Daniel.Berger at qwest.com
Wed Oct 24 14:59:29 EDT 2007


> -----Original Message-----
> From: rubygems-developers-bounces at rubyforge.org 
> [mailto:rubygems-developers-bounces at rubyforge.org] On Behalf 
> Of Eric Hodel
> Sent: Wednesday, October 24, 2007 10:19 AM
> To: rubygems-developers at rubyforge.org
> Subject: Re: [Rubygems-developers] Asking me for prerequisites
> 
> 
> On Oct 23, 2007, at 12:46 , Jim Weirich wrote:
> > On Oct 23, 2007, at 3:32 PM, Berger, Daniel wrote:
> >> Sorry if I've missed this.
> >>
> >> Is the latest rubygems not going to ask me if I want to install 
> >> prerequisites? Because with the current svn version it 
> just installs 
> >> them without asking. On Windows, anyway.
> >
> > That is correct, the default behavior was changed.
> 
> It now behaves more like macports or FreeBSD's ports which 
> seems more  
> sensible.  If you want the old behavior, use --ignore-dependencies.

Warning: bikeshed alert. :)

Using '--ignore-dependencies' means it will ask me before installing
dependencies?

That seems like an odd switch name then. I vote for '--ask-dependencies'
instead. I would tuit '--ignore-dependencies' to mean 'just install the
damn thing, don't try to grab the dependencies at all'.

Just a thought.

Regards,

Dan


This communication is the property of Qwest and may contain confidential or
privileged information. Unauthorized use of this communication is strictly 
prohibited and may be unlawful.  If you have received this communication 
in error, please immediately notify the sender by reply e-mail and destroy 
all copies of the communication and any attachments.


More information about the Rubygems-developers mailing list