[Rubygems-developers] Questions about Gem Platform Matching

Eric Hodel drbrain at segment7.net
Mon Oct 1 03:32:06 EDT 2007


On Sep 30, 2007, at 08:38 , Luis Lavena wrote:
>> Should we make this check in Gem::Platform.local and choose x86-
>> mswin32-80 or x86-mswin32-60 (I think those are right) based on which
>> one it is?
>>
>
> This sounds good, since Ruby set the platform to mswin32_80 .. adding
> -60 to the VC6 version sounds right.

I modified your patch and committed this:

-------------- next part --------------
A non-text attachment was scrubbed...
Name: platform.rb.vc6.patch
Type: application/octet-stream
Size: 3140 bytes
Desc: not available
Url : http://rubyforge.org/pipermail/rubygems-developers/attachments/20071001/be94161f/attachment-0001.obj 
-------------- next part --------------

Does it look right?

(Next changelog commit will have proper credit, oops!)

--
Poor workers blame their tools. Good workers build better tools. The
best workers get their tools to do the work for them. -- Syndicate Wars




More information about the Rubygems-developers mailing list