[Rubygems-developers] getting an error using mongrel that might be gem related

Stephen Bannasch stephen.bannasch at deanbrook.org
Thu Nov 15 02:43:09 EST 2007

At 1:53 PM -0800 11/14/07, Eric Hodel wrote:
>On Nov 13, 2007, at 22:32 , Jeremy Hinegardner wrote:
>> On Tue, Nov 13, 2007 at 10:02:16PM -0800, Eric Hodel wrote:
>>> On Nov 13, 2007, at 21:46 , Stephen Bannasch wrote:
>>>> At 6:03 PM -0800 11/13/07, Eric Hodel wrote:
>>>>> Nothing in this stack trace points to RubyGems.
>>>> The crash appears to be happening in
>>>> GemPlugin::Manager.instance.load (but of course things are not
> >>> always as they appear).
>>> GemPlugin is not part of RubyGems.  I think its part of mongrel.
>> I would be you have a gem installed that depends on GemPlugin but
>> doesn't have an init.rb or fails to initialize itself correctly.  Try
>> this and see what happens:
>>     require 'rubygems'
>>     require 'mongrel'
>>     g = GemPlugin::Manager.instance
>>     g.load( {'mongrel' => GemPlugin::INCLUDE })
>>     puts g.gems.inspect
>> If that blows up then its probably some gem that depends on mongrel 
>> not
>> initalizing correctly.
>If it isn't failing with a stack trace that points to RubyGems then 
>you'll need to go ask the GemPlugin author for support.  I haven't
>seen such a stack trace yet.

Eric and Jeremy, Thanks for all your responses -- they definitely helped me spend less time in dead-end investigations.

I was confused (and tired) when I was tracing through the gem_plugin code and confused it with gem proper. GemPlugin was written by the author of mongrel Zed Shaw.

I think it is possible that some gems have gotten corrupted however.

I was able to get rails and mongrel to start up properly by uninstalling ruport v0.8.12 -- that gem should have nothing to do with rails or mongrel??

Anyways if you are interested here's a link to a longer report I made on the debugging I did in Mongrel and gem_plugin on the mongrel-users email list:


>From Zed's description of gem_plugin:

# Implements a dynamic plugin loading, configuration, and discovery system
# based on RubyGems and a simple additional name space that looks like a URI.


In further testing I discovered:

After uninstalling ruport 0.8.11, 0.8.12, and 1.2.2 starting rails and mongrel worked.

After re-installing ruport 1.2.2 starting rails and mongrel worked.

After re-installing ruport 0.8.12 starting rails and mongrel DID NOT work.

After uninstalling ruport 1.2.2 starting rails and mongrel DID NOT work.

After uninstalling ruport 0.8.12 starting rails and mongrel worked.

Here's a link to that actual testing: http://pastie.caboo.se/118251

The error messages were not helpful in tracking this problem down.

More information about the Rubygems-developers mailing list