[Rubygems-developers] getting an error using mongrel that might be gem related

Jeremy Hinegardner jeremy at hinegardner.org
Wed Nov 14 01:32:00 EST 2007

On Tue, Nov 13, 2007 at 10:02:16PM -0800, Eric Hodel wrote:
> On Nov 13, 2007, at 21:46 , Stephen Bannasch wrote:
> > At 6:03 PM -0800 11/13/07, Eric Hodel wrote:
> >>
> >> Nothing in this stack trace points to RubyGems.
> >
> > The crash appears to be happening in  
> > GemPlugin::Manager.instance.load (but of course things are not  
> > always as they appear).
> GemPlugin is not part of RubyGems.  I think its part of mongrel.

I would be you have a gem installed that depends on GemPlugin but
doesn't have an init.rb or fails to initialize itself correctly.  Try
this and see what happens:

    require 'rubygems'
    require 'mongrel'
    g = GemPlugin::Manager.instance
    g.load( {'mongrel' => GemPlugin::INCLUDE })
    puts g.gems.inspect

If that blows up then its probably some gem that depends on mongrel not
initalizing correctly.



 Jeremy Hinegardner                              jeremy at hinegardner.org 

More information about the Rubygems-developers mailing list