[Rubygems-developers] getting an error using mongrel that might be gem related

Stephen Bannasch stephen.bannasch at deanbrook.org
Tue Nov 13 21:15:19 EST 2007


>On Nov 13, 2007, at 14:28 , Stephen Bannasch wrote:
>> somebody probably wiser than me wrote:
>>> IIRC, if you update ruby, you're supposed to reinstall your gems --
>>> especially those with C components. (You'll probably want to update
>>> mysql, too.) Something about libraries and linking...?
>>
>> I didn't do that -- and that sounds like a likely cause for strange 
>> errors.
>
>I've never heard of this before, and I've been using gems for a long 
>time.  I've never reinstalled my gems when upgrading ruby.  I've used 
>C components from ruby 1.8.2 with 1.8.6.

Well -- your experience certainly lowers the probability of that being the cause. I'll get back to learning more about ruby-debug and tracing out the issue.


More information about the Rubygems-developers mailing list