[Rubygems-developers] getting an error using mongrel that might be gem related

Eric Hodel drbrain at segment7.net
Tue Nov 13 21:02:37 EST 2007


On Nov 13, 2007, at 14:28 , Stephen Bannasch wrote:
> somebody probably wiser than me wrote:
>> IIRC, if you update ruby, you're supposed to reinstall your gems --
>> especially those with C components. (You'll probably want to update
>> mysql, too.) Something about libraries and linking...?
>
> I didn't do that -- and that sounds like a likely cause for strange  
> errors.

I've never heard of this before, and I've been using gems for a long  
time.  I've never reinstalled my gems when upgrading ruby.  I've used  
C components from ruby 1.8.2 with 1.8.6.

If you do have to recompile, this is a bug in either Ruby or the  
extension because something changed incompatibly.  Probably the  
extension though.

--
Poor workers blame their tools. Good workers build better tools. The
best workers get their tools to do the work for them. -- Syndicate Wars




More information about the Rubygems-developers mailing list