[Rubygems-developers] Deep thoughts about 0.9.4.6

Luis Lavena luislavena at gmail.com
Fri Nov 9 22:44:41 EST 2007


On Nov 9, 2007 10:10 PM, Eric Hodel <drbrain at segment7.net> wrote:
>
> I changed things around some by storing a Gem::Platform in
> @new_platform, and leaving @platform alone (as best I could).  This
> should fix the YAML problems with respect to backwards compatibility.
>
> > Shouldn't the gem specification version be bumped one time and
> > encapsulate these "differences"?
>
> It has, but the code in Gem::Specification doesn't handle forward-
> compatiblity well.  I've worked around it as much as I can.
>

Thank you Eric.

I understand the complexity of the situation, also that RubyGems could
came the point of failure of the whole ruby-on-your-platform since
almost every ruby library or application right now is bundled as gem.

And everybody knows that you exceed the average expectations on fixing
and finding solutions or workaround for all these problems.

Again, thank you :-)

-- 
Luis Lavena
Multimedia systems
-
Leaders are made, they are not born. They are made by hard effort,
which is the price which all of us must pay to achieve any goal that
is worthwhile.
Vince Lombardi


More information about the Rubygems-developers mailing list