[Rubygems-developers] Deep thoughts about

Luis Lavena luislavena at gmail.com
Thu Nov 8 15:37:34 EST 2007

Hello List,

Been working along this beta since a few weeks backs, so my understand
could not match the one of the creators or big contributors, but found
a few issues that I'll really appreciate some insight.

- Latest beta always try to use SSL (OpenSSL or SSL in the jruby) even
when you don't ask for it (filled a ticket about this).
- Currently some gems shipped with "jruby" as platform got missed by
the new Indexer:

irb(main):003:0> Gem::Platform.local
=> #<Gem::Platform:0x10 @cpu="x86", @os="java", @version="1.6">
irb(main):004:0> Gem::Platform.new 'jruby'
=> #<Gem::Platform:0x12 @cpu=nil, @os="unknown", @version=nil>

- Also, the indexer miss some gems due "misnamed gem", which was
discussed previously.

This raises a new issue: chicken-egg situation: using the new yaml
index will force the clients to have latest rubygems to work with,
since platform: reference in the spec is now a class.

Shouldn't the gem specification version be bumped one time and
encapsulate these "differences"?

Again, I'm exposing this in my low understanding of the real situation :-)

(dumping this here for future references) :-)
Luis Lavena
Multimedia systems
Leaders are made, they are not born. They are made by hard effort,
which is the price which all of us must pay to achieve any goal that
is worthwhile.
Vince Lombardi

More information about the Rubygems-developers mailing list