[Rubygems-developers] What is right and wrong with dependencies definitions?

Luis Lavena luislavena at gmail.com
Wed Nov 7 10:58:29 EST 2007


On 11/7/07, Austin Ziegler <halostatue at gmail.com> wrote:
>
> Yeah. It'd just be nice if we could say:
>
>   gem install --for-development foobar
>

Sound good, but too verbose. I like the build-dep command of apt-get
(that's the only thing I like, for the record) :-)

> Mostly, the problem is the same as everything else... someone needs to
> take the time to make a patch ;)

This will require adding the new command, the new
development_dependency (or build_dependency) to the specs and make
check command use this instead.

I'm trying to collect enough info to make this happen, then I can
create a patch and submit to rubyforge. :-D

-- 
Luis Lavena
Multimedia systems
-
Leaders are made, they are not born. They are made by hard effort,
which is the price which all of us must pay to achieve any goal that
is worthwhile.
Vince Lombardi


More information about the Rubygems-developers mailing list