[Rubygems-developers] Gem install not working?

Trans transfire at gmail.com
Mon Nov 5 14:09:32 EST 2007


On Nov 5, 2007 12:19 PM, Luis Lavena <luislavena at gmail.com> wrote:
> On 11/5/07, Trans <transfire at gmail.com> wrote:
> > Something isn't right...
> >
> > trans at transhuttlex:~/Ruby/tmail/trunk$ sudo gem install rake
> > [sudo] password for trans:
> > Need to update 3 gems from http://gems.rubyforge.org
> > ...
> > complete
> > Successfully installed rake-0.7.3
> > Installing ri documentation for rake-0.7.3...
> > Installing RDoc documentation for rake-0.7.3...
> > trans at transhuttlex:~/Ruby/tmail/trunk$ less /usr/local/lib/site_ruby/1.8/
> > i486-linux/ oll.rb      pony/       ratch/      roll/
> > trans at transhuttlex:~/Ruby/tmail/trunk$ rake -T
> > The program 'rake' is currently not installed.  You can install it by typing:
> > sudo apt-get install rake
>
> 1a) what is your gem env result?
> 1b) did oyu manually install gem?
> 1c) what options did you use to install it?

It was a debian install of gems. I just tossed it and installed form
source. All better now :-)

> 2) is there a debian package for rake?

Yes, but I wanted to install via gems.

T.


More information about the Rubygems-developers mailing list