[Rubygems-developers] How to bundle up MS Windows version separately

Mikel Lindsaar raasdnil at gmail.com
Sun Nov 4 22:35:17 EST 2007


Hello all,

Please forgive the newbie question.

I am wondering if anyone has a good link / resource / howto, whatever
on how you make a windows gem or a different version so that you get
this sort of output on gem install:

Select which gem to install for your platform (i386-openbsd4.1)
 1. hpricot 0.6 (mswin32)
 2. hpricot 0.6 (jruby)
 3. hpricot 0.6 (ruby)
 4. ...

I thought it might be as easy as naming the file with -mswin32 on the
end.. but alas, I think I am incorrect.

I looked through the rubygems docs on the website, and either one of
two things happened.

(1) I missed it due to lack of sleep (highly probably)
(2) The answer is not there (less likely)

If anyone could shine some light in this direction, that would be great!

Thanks

Mikel


More information about the Rubygems-developers mailing list