[Rubygems-developers] Gem repository and/or local gem installation issues

Wes Gamble weyus at att.net
Fri Mar 16 16:53:13 EDT 2007


I had to revert back to 0.9.0 to get gem to work again.  

Looks like there are a lot of issues w/0.9.2 at least.  Maybe 0.9.1 as well on Win XP?

Any insight into the quality of 0.9.1/0.9.2.  

Thanks,
Wes

-------------- Original message ----------------------
From: weyus at att.net (Wes Gamble)
>
> I think we've ruled the firewall out.  Is there a way to blow away my local gem 
> index?  I can't find any instructions in the rubygems manual online?
> 
> Thanks,
> WG
> 
> -------------- Original message ----------------------
> From: weyus at att.net (Wes Gamble)
> >
> > This may be due to firewall issues on my side.  Does that sound right?
> > 
> > WG
> > 
> > -------------- Original message ----------------------
> > From: weyus at att.net (Wes Gamble)
> > >
> > > All,
> > > 
> > > I've attempted to update several gems and I keep getting an "invalid gem 
> > format" 
> > > error.  Below is the output of my various gem update commands.  
> > > 
> > > gem 0.9.2
> > > Windows XP
> > > 
> > > Is there something going on with the repository or is the problem with my 
> > local 
> > > installation?  If the problem is local, how should I go about debugging it?
> > > 
> > > Thanks,
> > > Wes
> > > ========================================
> > > C:\eclipse\workspace>gem update rubyful_soup
> > > Updating installed gems...
> > > Attempting remote update of rubyful_soup
> > > ERROR:  While executing gem ... (Gem::InstallError)
> > >     invalid gem format for 
> > > c:/ruby/lib/ruby/gems/1.8/cache/rubyful_soup-1.0.4.gem
> > > 
> > > C:\eclipse\workspace>gem update rake
> > > Updating installed gems...
> > > Attempting remote update of rake
> > > ERROR:  While executing gem ... (Gem::InstallError)
> > >     invalid gem format for c:/ruby/lib/ruby/gems/1.8/cache/rake-0.7.2.gem
> > > 
> > > C:\eclipse\workspace>gem update
> > > Updating installed gems...
> > > Attempting remote update of actionmailer
> > > Install required dependency actionpack? [Yn]  Y
> > > Install required dependency activesupport? [Yn]  Y
> > > ERROR:  While executing gem ... (Gem::InstallError)
> > >     invalid gem format for 
> > > c:/ruby/lib/ruby/gems/1.8/cache/activesupport-1.4.2.gem
> > > _______________________________________________
> > > Rubygems-developers mailing list
> > > Rubygems-developers at rubyforge.org
> > > http://rubyforge.org/mailman/listinfo/rubygems-developers
> > 
> > 
> > _______________________________________________
> > Rubygems-developers mailing list
> > Rubygems-developers at rubyforge.org
> > http://rubyforge.org/mailman/listinfo/rubygems-developers
> 
> 
> _______________________________________________
> Rubygems-developers mailing list
> Rubygems-developers at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rubygems-developers




More information about the Rubygems-developers mailing list