[Rubygems-developers] index_gem_repository problem

Steve Conover sconover at gmail.com
Wed Mar 14 00:18:30 EDT 2007


Zero-length files did it but a bunch of others did too.  I threw a
begin-rescue around that block and printed out all the gems I get
exceptions from.  Perhaps it's the place I rsync'ed from?  I did the
following:

rsync -av rsync://rubyforge.lauschmusik.de/gems/ .

I'm on ubuntu dapper using ruby 1.8.4.  I've rsync'ed a couple times
and had the same results.

Thanks for your help.  -Steve

Here's the list:

./gems/Pn4-0.1.0-win32-1.8.4-VC6.gem had a problem, skipping
./gems/bcrypt-ruby-1.0.0.gem had a problem, skipping
./gems/bcrypt-ruby-2.0.0.gem had a problem, skipping
./gems/bcrypt-ruby-2.0.1.gem had a problem, skipping
./gems/core_ex-0.1.2.gem had a problem, skipping
./gems/pqa-1.6.gem had a problem, skipping
./gems/rant-0.3.0.gem had a problem, skipping
./gems/rant-0.3.2.gem had a problem, skipping
./gems/rant-0.3.4.gem had a problem, skipping
./gems/rant-0.3.6.gem had a problem, skipping
./gems/rant-0.3.8.gem had a problem, skipping
./gems/rant-0.4.0.gem had a problem, skipping
./gems/rant-0.4.2.gem had a problem, skipping
./gems/rant-0.4.4.gem had a problem, skipping
./gems/rant-0.4.6.gem had a problem, skipping
./gems/rant-0.4.8.gem had a problem, skipping
./gems/rant-0.5.0.gem had a problem, skipping
./gems/rant-0.5.2.gem had a problem, skipping
./gems/rant-0.5.4.gem had a problem, skipping
./gems/rant-0.5.6.gem had a problem, skipping
./gems/rant-0.5.7.gem had a problem, skipping
./gems/rspec-0.7.0.gem had a problem, skipping
./gems/rspec-0.7.1.gem had a problem, skipping
./gems/rspec-0.7.2.gem had a problem, skipping
./gems/rspec-0.7.3.gem had a problem, skipping
./gems/rspec-0.7.4.gem had a problem, skipping
./gems/rspec-0.7.5.1.gem had a problem, skipping
./gems/rspec-0.7.5.gem had a problem, skipping
./gems/rspec-0.8.0.gem had a problem, skipping
./gems/rspec-0.8.1.gem had a problem, skipping
./gems/rspec-0.8.2.gem had a problem, skipping
./gems/ruby_ex-0.1.1.gem had a problem, skipping
./gems/statemachine-0.0.0.gem had a problem, skipping
./gems/statemachine-0.0.1.gem had a problem, skipping
./gems/stompserver-0.9.0.gem had a problem, skipping
./gems/win32screenshot-0.0.3.gem had a problem, skipping

On 3/12/07, Jim Weirich <jim.weirich at gmail.com> wrote:
> On 3/12/07, Jim Weirich <jim.weirich at gmail.com> wrote:
> > [...]
> > I would recommend double check that all the .gem files are readable and
> > have good data (a zero length .gem file could possibly cause this
> > problem).
>
> FYI, a quick check on my system shows that a zero length gem file does
> indeed reproduce the same error you are getting, so that's a good
> place to start checking.
>
> --
> -- Jim Weirich    jim at weirichhouse.org     http://onestepback.org
> -----------------------------------------------------------------
> "Beware of bugs in the above code; I have only proved it correct,
> not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)
> _______________________________________________
> Rubygems-developers mailing list
> Rubygems-developers at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rubygems-developers
>


More information about the Rubygems-developers mailing list