[Rubygems-developers] Two versions of ruby 1.8.x on same system with working rubygems, possible?

Rick DeNatale rick.denatale at gmail.com
Wed Mar 7 12:28:50 EST 2007

I might be trying to do something which is impossible.

I've got both ruby 1.8.5 and 1.8.6 installed on a system as well as
ruby1.9  the libraries are in


I'd like now to install rubygems  so that it can be used with either
1.8.5 OR 1.8.6  but I can't figure out which options to use with
setup.rb in order to do this.  I'd be happy if these were two separate
rubygems installs, but it would be great if the gems could be shared
if that made sense.

Is this even possible?  Looking at the code in setup.rb it seems to
disregard the tiny part of the ruby version.

Rick DeNatale

More information about the Rubygems-developers mailing list