[Rubygems-developers] muti-packaging

TRANS transfire at gmail.com
Sat Mar 3 15:22:28 EST 2007

(Posted this to Ruby-talk then realized it would be better here)

Any chance of getting RubyGems to support the packages/ dir that's
supported by setup.rb?  I currently have to run a custom staging task
before I can create a gem for a project that has subprojects.

Alternatively, RubyGem multi-packages might be nice. Installing a
multi-package would install dependent packages, but would behave as if
it were a single package.

Another thought, is to create a "GemCruncher" that could take a set of
gems and merge them into a single gem.


More information about the Rubygems-developers mailing list