[Rubygems-developers] 0.9.4 setup.rb on Gentoo hangs

Tom Lieber alltom at gmail.com
Wed Jun 6 08:21:06 EDT 2007


On 6/6/07, Eric Hodel <drbrain at segment7.net> wrote:
> On Jun 5, 2007, at 19:29, Tom Lieber wrote:
> > I'm trying to install RubyGems on Gentoo. I first tried with emerge,
> > but that install hung, so I tried by installing from the the 0.9.4
> > tarball. This is where it stops:
> >
> > mkdir -p /usr/lib/ruby/site_ruby/1.8/rbconfig
> > install datadir.rb /usr/lib/ruby/site_ruby/1.8/rbconfig
> > <--- lib/rbconfig
> > <--- lib
> >   Successfully built RubyGem
> >   Name: sources
> >   Version: 0.0.1
> >   File: sources-0.0.1.gem
> >
> > When I Ctrl+C, I get this stack trace:
> >
> > /usr/lib/ruby/site_ruby/1.8/rubygems/package.rb:335:in
> > `initialize': Interrupt
> >         from /usr/lib/ruby/site_ruby/1.8/rubygems/package.rb:446:in
> > `new'
> >         from /usr/lib/ruby/site_ruby/1.8/rubygems/package.rb:446:in
> > `each_entry'
> >         from /usr/lib/ruby/site_ruby/1.8/rubygems/package.rb:442:in
> > `loop'
> >         from /usr/lib/ruby/site_ruby/1.8/rubygems/package.rb:442:in
> > `each_entry'
> >         from /usr/lib/ruby/site_ruby/1.8/rubygems/package.rb:427:in
> > `each'
> >         from /usr/lib/ruby/site_ruby/1.8/rubygems/package.rb:488:in
> > `initialize'
> >         from /usr/lib/ruby/site_ruby/1.8/rubygems/package.rb:586:in
> > `new'
> >         from /usr/lib/ruby/site_ruby/1.8/rubygems/package.rb:586:in
> > `open_from_io'
> >          ... 10 levels...
> >         from setup.rb:1000:in `exec_install'
> >         from setup.rb:814:in `invoke'
> >         from setup.rb:773:in `invoke'
> >         from setup.rb:1578
> >
> > What could this be?
>
> What does:
>
> ruby -rrbconfig -e 'p Config::CONFIG["CFLAGS"]'
>
> say?

-Os -march=pentium4 -pipe  -fPIC

Sincerely,

Tom Lieber
http://AllTom.com/
http://GadgetLife.org/


More information about the Rubygems-developers mailing list