[Rubygems-developers] rubygems' cooperation with linux distributions?

Nguyễn Thái Ngọc Duy pclouds at gentoo.org
Mon Jan 22 02:13:32 EST 2007


On 1/22/07, Eric Hodel <drbrain at segment7.net> wrote:
> > Well for Gentoo I do not think that is the way to go. You may waste
> > your CPU power to reemerge ruby just for changing one line in
> > rbconfig.rb. I would prefer gem packages can rerun make with a
> > modified makefile. (It may be not the best way though)
>
> mkmf.rb (which is required by extconf.rb) is the place to look to see
> if you can override Config::CONFIG['INSTALL'], perhaps with an
> environment variable.  It should get passed straight from the gem
> install command down to the extconf.rb in a subshell.  If not, please
> file a bug on our tracker.

Thank you. I am currently at work though. I will try that later.
-- 
Duy


More information about the Rubygems-developers mailing list