[Rubygems-developers] rubygems' cooperation with linux distributions?

Jim Weirich jim at weirichhouse.org
Sun Jan 21 18:34:48 EST 2007


Nguyễn Thái Ngọc Duy wrote:
 > rubygems' related problems happened again in Gentoo land [1]. In
 > short, I need to intervene gem building process to patch ruby
 > extension building. Currently there is no non-hacky way to patch a gem
 > package as far as I know. If you know some ways, please kindly teach
 > me.

Hi.  Thanks for posting on this list.  However, I'm not sure I'm sure 
what you are asking for.  The location of the install program is not 
specified in RubyGems in any way.  Are you asking for a easy RubyGems 
way of fixing this more general problem.  If so, perhaps you could be 
more specific on what you would like to see changed.

 > And I would like to know whether rubygems is going to be more
 > distro-friendly (well, I mean Gentoo-friendly, although I do know
 > about Deb/RPM packaging so I am pretty sure they will face the same
 > problems Gentoo have). If it does, how is the plan?

We have made several changes in the past that were suggested by 
distro-maintainers, and would like to continue to work with repackagers 
to make their job easy.  Feel free to make suggestions for improvements.

-- Jim Weirich


More information about the Rubygems-developers mailing list