[Rubygems-developers] rubygems' cooperation with linux distributions?

Nguyễn Thái Ngọc Duy pclouds at gentoo.org
Sun Jan 21 10:54:06 EST 2007


Hi,

I am a Gentoo Linux developer. I sent a mail to this list long ago
about modifying rubygems for better cooperation between rubygems and
Gentoo but it seemed to be ignored. Maybe I was so bad at expressing
things. I hope I am not so bad this time. If it is, then it is really
not my intention, English is not my first language.

rubygems' related problems happened again in Gentoo land [1]. In
short, I need to intervene gem building process to patch ruby
extension building. Currently there is no non-hacky way to patch a gem
package as far as I know. If you know some ways, please kindly teach
me.

And I would like to know whether rubygems is going to be more
distro-friendly (well, I mean Gentoo-friendly, although I do know
about Deb/RPM packaging so I am pretty sure they will face the same
problems Gentoo have). If it does, how is the plan?

Best regards,

[1] https://bugs.gentoo.org/show_bug.cgi?id=159922
-- 
Duy


More information about the Rubygems-developers mailing list