[Rubygems-developers] TODO: Better name # How about...

Hugh Sasse hgs at dmu.ac.uk
Fri Jan 19 12:16:25 EST 2007


Reading through 0.9.1 (newest tarball I could find) as I 
wanted to dev patches for docpath,  in cmd_manager:

  ###################################################################
  # Signals that local installation will not proceed, not that it has
  # been tried and failed.  TODO: better name.
  class LocalInstallationError < Gem::Exception; end


OK, how about 

  class LocalInstallHalted < Gem::Exception; end

Should convey that things have come to a stop, so we don't
need to call it Error.  Seems to be unused, so far.

        Hugh


More information about the Rubygems-developers mailing list