[Rubygems-developers] gemwhich and version problems

Jim Freeze rubygems at freeze.org
Sun Jan 7 21:59:15 EST 2007


On Jan 7, 2007, at 8:04 PM, Jim Weirich wrote:
Gemwhich works off of file names that are loaded via require, not gem
names.  Try:

   gemwhich active_record/base

Ok, thanks. But, I thought that it would handle commandline apps.
What if a gem doesn't have a library, but only a commandline app?


% rails _1.1.6.5848_ -v
/opt/local/ruby-1.8.4/lib/ruby/site_ruby/1.8/rubygems.rb:251:in
`report_activate_error': RubyGem version error: rails(1.0.0 not =
1.1.6.5848) (Gem::LoadError)
[...]
I thought rubygems was supposed to be able to handle any number of  
segments
in a version.

Is version 1.1.6.5848 installed as a gem?  Or is it installed from SVN?

As a gem.

% ls -ld *
drwxr-xr-x    9 root  admin  306 Jan  6 23:12 actionmailer-1.2.5
drwxr-xr-x    9 root  admin  306 Jan  6 23:22 actionmailer-1.2.5.5848
drwxr-xr-x   12 root  admin  408 Jan  6 23:12 actionpack-1.12.5
drwxr-xr-x   11 root  admin  374 Jan  6 23:22 actionpack-1.12.5.5848
drwxr-xr-x   11 root  admin  374 Jan  6 23:12 actionwebservice-1.1.6
drwxr-xr-x   11 root  admin  374 Jan  6 23:22  
actionwebservice-1.1.6.5848
drwxr-xr-x   10 root  admin  340 Jan  6 23:12 activerecord-1.14.4
drwxr-xr-x   10 root  admin  340 Jan  6 23:22 activerecord-1.14.4.5848
drwxr-xr-x    4 root  admin  136 Jan  6 23:11 activesupport-1.3.1
drwxr-xr-x    5 root  admin  170 Jan  6 23:22 activesupport-1.3.1.5848
% pwd
/opt/local/ruby-1.8.5-p12/lib/ruby/gems/1.8/gems


Jim Freeze
\



-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/rubygems-developers/attachments/20070107/89b2ea7b/attachment.html 


More information about the Rubygems-developers mailing list