[Rubygems-developers] gemwhich and version problems

Jim Weirich jim.weirich at gmail.com
Sun Jan 7 21:04:33 EST 2007


On 1/7/07, Jim Freeze <rubygems at freeze.org> wrote:
>
> % gem list rails
>
> *** LOCAL GEMS ***
>
> rails (1.1.6.5848, 1.1.6)
>     Web-application framework with template engine, control-flow layer,
>     and ORM.
> % gemwhich rails
> Can't find rails

Gemwhich works off of file names that are loaded via require, not gem
names.  Try:

  gemwhich active_record/base

> % rails _1.1.6.5848_ -v
> /opt/local/ruby-1.8.4/lib/ruby/site_ruby/1.8/rubygems.rb:251:in
> `report_activate_error': RubyGem version error: rails(1.0.0 not =
> 1.1.6.5848) (Gem::LoadError)
[...]
> I thought rubygems was supposed to be able to handle any number of segments
> in a version.

Is version 1.1.6.5848 installed as a gem?  Or is it installed from SVN?

-- 
-- Jim Weirich    jim at weirichhouse.org     http://onestepback.org
-----------------------------------------------------------------
"Beware of bugs in the above code; I have only proved it correct,
not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)


More information about the Rubygems-developers mailing list