[Rubygems-developers] Problem with 0.9.0.9

Eric Hodel drbrain at segment7.net
Sun Jan 7 20:09:37 EST 2007


On Jan 7, 2007, at 04:33, Christopher McGrath wrote:

> Hi, Just tried out the latest beta. I can install gems from local
> files, but when I try to install/update remote gems I get.
>
> $ sudo gem install capistrano --inc --backtrace
> ERROR:  While executing gem ... (NoMethodError)
>      undefined method `source_index' for #<Hash:0x1420198>
> /opt/local/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:81:in
> `source_index_hash'
> /opt/local/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:80:in
> `each'
> /opt/local/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:80:in
> `source_index_hash'
> /opt/local/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:91:in
> `specs_n_sources_matching'
> /opt/local/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:114:in
> `find_gem_to_install'
> /opt/local/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:57:in
> `install'
> /opt/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:274:in
> `execute'
> /opt/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:236:in  
> `each'
> /opt/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:236:in
> `execute'
> /opt/local/lib/ruby/site_ruby/1.8/rubygems/command.rb:70:in `invoke'
> /opt/local/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:120:in
> `process_args'
> /opt/local/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:91:in `run'
> /opt/local/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:30:in `run'
> /opt/local/bin/gem:23

What is the output of `sudo gem sources`?

Can you send the contents of /opt/local/lib/ruby/gems/1.8/source_cache?

Can you then try deleteing the file and trying again?

-- 
Eric Hodel - drbrain at segment7.net - http://blog.segment7.net

I LIT YOUR GEM ON FIRE!



More information about the Rubygems-developers mailing list