[Rubygems-developers] On cygwin -- update --system gives error.

Eric Hodel drbrain at segment7.net
Wed Feb 7 13:54:14 EST 2007


On Feb 7, 2007, at 01:54, Hugh Sasse wrote:
> Installing the latest Rubygems gem on cygwin just gave me:
>
> install timer.rb /usr/lib/ruby/site_ruby/1.8/rubygems
> install user_interaction.rb /usr/lib/ruby/site_ruby/1.8/rubygems
> install validator.rb /usr/lib/ruby/site_ruby/1.8/rubygems
> install version.rb /usr/lib/ruby/site_ruby/1.8/rubygems
> <--- lib/rubygems
> <--- lib
>   Successfully built RubyGem
>   Name: sources
>   Version: 0.0.1
>   File: sources-0.0.1.gem
> hook /usr/lib/ruby/gems/1.8/gems/rubygems-update-0.9.2/./post- 
> install.rb failed:
>
> undefined method `post_install_message' for #<Gem::Specification: 
> 0x7fe88a30>
> Try 'ruby setup.rb --help' for detailed usage.
> RubyGems system software updated

Please run:

ruby -d setup.rb

> hgs at Q2P14HGS ~
>
> I'm not sure which version I was updating from, and have forgotten  
> how to
> find out the versions I have.  Is this worth exploring further, or  
> shall I
> just leave it?

gem env


More information about the Rubygems-developers mailing list