[Rubygems-developers] Comeback of auth httpproxy problem

Anatol Pomozov anatol.pomozov at gmail.com
Sun Feb 4 00:47:31 EST 2007

Hi, Jim.

On 2/2/07, Jim Weirich <jim.weirich at gmail.com> wrote:
> On 2/2/07, Anatol Pomozov <anatol.pomozov at gmail.com> wrote:
> > I dig into this problem and found that it happens because new version of
> > rubygems do not contain open-uri library. And current version uses
> open-uri
> > from standard package.
> Thanks.  As I am now working behind a corporate firewall of superhuman
> strength, I appreciate this patch.  Now, if we could get it to work
> with a proxy using NTLM authentication, even I would be happy.

AFAIK most of the corporate proxies support several authentication methods.
My corporate firewall uses Basic, NTLM, Digest.

If you are trying to add NTLM proxy support you should look into Net:HTTP
package, cause open-uri uses it.

This is a easy thing to miss.  I will put a challenge out there for
> someone to come up with a good test of the proxy functionality so that
> we don't accidently lose this feature again.

 I'll try to write at least simple test. But I am not sure how to implement
'good test for the proxy functionality'.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/rubygems-developers/attachments/20070204/647ed6ba/attachment.html 

More information about the Rubygems-developers mailing list