[Rubygems-developers] [rubygems] Build still broken (#1205)

Jim Weirich jim.weirich at gmail.com
Sat Feb 3 23:19:22 EST 2007

On 2/2/07, Cerberus <anatol.pomozov at gmail.com> wrote:

> 295 tests, 1019 assertions, 9 failures, 19 errors
> rake aborted!
> Command failed with status (1): [C:/Program Files/ruby/bin/ruby -w -Ilib "C...]

Wow, this is terrible!

I haven't been watching the gem code base too closely recently.  But
today I updated my working copy with the intention of adding the
authenticating proxy with user/password support patch.  I ran the unit
tests and was surprised to see around 10 failing tests on my box.  I
spent most of my time today locating and fixing those errors before
finally getting around to auth-proxy patch.

I finally got clean builds on my box.  I strongly suggest we get the
code base to clean builds on Cerebus too.  With Chad's "unpack" fix
and anatol's proxy patch, I'd like to get a bug fix version out
quickly.  But I would really like to see these unit tests running
clean first.

Go Team!

-- Jim Weirich    jim at weirichhouse.org     http://onestepback.org
"Beware of bugs in the above code; I have only proved it correct,
not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)

More information about the Rubygems-developers mailing list