[Rubygems-developers] cannot specify multiple required_ruby_versions.

Austin Ziegler halostatue at gmail.com
Sat Dec 29 09:59:18 EST 2007


On Dec 29, 2007 2:06 AM, Luis Lavena <luislavena at gmail.com> wrote:
> Hello everybody,
>
> Since 1.9 is out, the use of required_ruby_version of
> Gem::Specification seems a good alternative to "allow any version of
> ruby from 1.8.4 but lower than 1.9.0"
>
> so, anyone will think: ok, I can do this:

What about

  spec.required_ruby_version = "~>1.8.4"

That should allow anything up to 1.8.9.9.9.9.9.9....

-austin
-- 
Austin Ziegler * halostatue at gmail.com * http://www.halostatue.ca/
               * austin at halostatue.ca * http://www.halostatue.ca/feed/
               * austin at zieglers.ca


More information about the Rubygems-developers mailing list