[Rubygems-developers] cannot specify multiple required_ruby_versions.

Luis Lavena luislavena at gmail.com
Sat Dec 29 02:06:15 EST 2007


Hello everybody,

Since 1.9 is out, the use of required_ruby_version of
Gem::Specification seems a good alternative to "allow any version of
ruby from 1.8.4 but lower than 1.9.0"

so, anyone will think: ok, I can do this:

spec.required_ruby_version = ['>=1.8.4', '<1.9.0']

then do rake gem and bingo, it gets build!

then, install:

gem install gem: gem installed successfuly!

irb:

require 'rubygems'
require 'test_gem'
ArgumentError: Illformed requirement [">= 1.8.4, < 1.9.0"]

This also happens when I try to uninstall the gem.

Rakefile:

http://pastie.caboo.se/132946

The required_ruby_version wasn't like that.

Ideas?

-- 
Luis Lavena
Multimedia systems
-
A common mistake that people make when trying to design
something completely foolproof is to underestimate
the ingenuity of complete fools.
Douglas Adams


More information about the Rubygems-developers mailing list