[Rubygems-developers] Questions on 1.0.0 on JRuby

Charles Oliver Nutter charles.nutter at sun.com
Thu Dec 20 18:33:09 EST 2007

1. jgem?

I saw this during the 1.0.0 install:

install -c -m 0755 /tmp/gem /Users/headius/NetBeansProjects/jruby/bin/jgem

Why jgem? We've been shipping with just 'gem'.

2. Some version issue on JRuby

I'm not positive this isn't because there's some old files straggling or 
a marshalling bug or something, but I'm seeing a case where a Version 
object has not had @ints initialized. This causes it to fail comparisons 
later on. Specifically, I'm seeing someting looking for a version 
"1.8.5" >= "0" at some point during Rails 2.0.2 install, which is when 
it blows up.

If I modify version.rb like so I do not see this problem, but I'm not 
sure why @ints isn't getting initialized on its own:

    def <=>(other)
      return 1 unless other
-    @ints <=> other.ints
+    @ints <=> other.to_ints

With this fix (and a Time marshalling bug in JRuby) I managed to get 
Rails 2.0.2 to install fine with RubyGems 1.0.0...so I'm keen to get 
JRuby upgraded.

- Charlie

More information about the Rubygems-developers mailing list