[Rubygems-developers] gem server problems in 0.9.5

Eric Hodel drbrain at segment7.net
Sun Dec 16 04:59:09 EST 2007

On Dec 15, 2007, at 21:39 PM, Chad Woolley wrote:
> On Dec 13, 2007 3:43 PM, Eric Hodel <drbrain at segment7.net> wrote:
>> On Dec 13, 2007, at 13:37 PM, Eric Hodel wrote:
>>> On Dec 11, 2007, at 24:30 AM, Chad Woolley wrote:
>>>> Is this a bug, or am I doing something wrong?
>>> You certainly shouldn't get 500s.  I'll look into it, but if you can
>>> run with --debug it might give a backtrace.
>> Fixed.
> This is still a problem with the trunk as of right now.  Here is my
> ruby-debug session, which shows the stack right before I get the
> exception.  It gets into fetch_single_spec, then blows up looking for
> a /quick/Marshal...rz file:
> [...]

Can you give me a log of it running without the debug stuff?  I need  
to know what's coming back from the server.  Also, your test gems may  
be useful in tracking this down.

I added some code that'll make RubyGems give a little more information  
when retrieval of files raises an error.  Be sure to have revision  
1550 or newer.

For what it's worth, I'm not having any problems with `gem server` out  
of trunk:

$ sudo ruby -Ilib bin/gem sources --clear
*** Removed user source cache ***
*** Removed system source cache ***
$ rm -r ~/tmp/gems
$ ruby -Ilib bin/gem install -i ~/tmp/gems --source http://localhost:8808 
Updating metadata for 16 gems from http://localhost:8808
Successfully installed rubyforge-0.4.4
Successfully installed rake-0.7.3
Successfully installed hoe-1.3.0
Successfully installed RubyInline-3.6.5
Successfully installed ParseTree-2.0.2
Successfully installed ruby2ruby-1.1.7
6 gems installed
[ri/rdoc installation follows]

I was also successful installing using 0.9.4, minus a few bugs that  
are present in 0.9.4.

The server was run as:

$ ruby -Ilib bin/gem server
Starting gem server on http://localhost:8808/
[GET/HEAD requests, all 200]

More information about the Rubygems-developers mailing list