[Rubygems-developers] Problems with OpenSSL requirement in RubyGems 0.9.5 and JRuby

Charles Oliver Nutter charles.nutter at sun.com
Fri Dec 14 01:07:55 EST 2007


Eric Hodel wrote:
> Done.  Removing openssl.rb and friends seems to work for me.
> 
> require 'rubygems'
> require 'rubygems/dependency_installer'
> 
> Gem::DependencyInstaller.new('rake', nil, :install_dir => '/tmp/ 
> gems').install
> 
> p Gem.ssl_available? # => false
> p $".grep(/openssl/i) # => ["rubygems/gem_openssl.rb"]

Excellent...we'll confirm it's all working correctly in JRuby. Any 
timeframe for the next big release? You had mentioned a 1.0 possibly in 
the future.

- Charlie


More information about the Rubygems-developers mailing list