[Rubygems-developers] Beta Time?

Jim Weirich jim.weirich at gmail.com
Mon Aug 27 13:51:08 EDT 2007


On Aug 26, 2007, at 4:03 PM, Eric Hodel wrote:

> On Aug 25, 2007, at 19:42, Chad Woolley wrote:
>> Sounds great.  I'll play with it.  Do you have to package it, or is
>> there a tag, or just use trunk?
>
> svn+ssh://rubyforge.org/var/svn/rubygems/tags/REL_0_9_4_4
>
> I sent packages to Jim, he should announce them in the next day or
> two when he gets a spare moment.

I'm having a problem with the beta version.  It complains about the  
POpen gem.  I uninstalled POpen and reinstalled it using the beta,  
but it still fails.  I suspect it is using a legacy platform issue.   
Here is the error message:


$ gem list rake
WARNING:  #<Gem::Exception: /opt/local/lib/ruby/site_ruby/1.8/ 
rubygems/specification.rb:302:in `platform=': invalid platform  
"unix", see Gem::Platform>
Gem::Specification.new do |s|
   s.name = %q{POpen4}
   s.version = "0.1.1"
   s.date = %q{2006-06-12}
   s.summary = %q{Open4 cross-platform}
   s.email = %q{john-mason at shackelford.org}
   s.autorequire = %q{popen4.rb}
   s.has_rdoc = true
   s.required_ruby_version = Gem::Requirement.new("> 0.0.0")
   s.required_rubygems_version = nil
   s.platform = %q{unix}
   s.authors = ["John-Mason P. Shackelford"]
   s.files = ["tests/popen4_test.rb", "lib/popen4.rb", "CHANGES",  
"ext", "lib", "LICENSE", "pkg", "Rakefile", "rdoc", "README", "tests"]
   s.add_dependency(%q<Platform>, [">= 0.4.0"])
   s.add_dependency(%q<open4>, [">= 0.4.0"])
end
WARNING:  Invalid .gemspec format in '/opt/local/lib/ruby/gems/1.8/ 
specifications/POpen4-0.1.1-unix.gemspec'

*** LOCAL GEMS ***

WARNING:  #<Gem::Exception: /opt/local/lib/ruby/site_ruby/1.8/ 
rubygems/specification.rb:302:in `platform=': invalid platform  
"unix", see Gem::Platform>
Gem::Specification.new do |s|
   s.name = %q{POpen4}
   s.version = "0.1.1"
   s.date = %q{2006-06-12}
   s.summary = %q{Open4 cross-platform}
   s.email = %q{john-mason at shackelford.org}
   s.autorequire = %q{popen4.rb}
   s.has_rdoc = true
   s.required_ruby_version = Gem::Requirement.new("> 0.0.0")
   s.required_rubygems_version = nil
   s.platform = %q{unix}
   s.authors = ["John-Mason P. Shackelford"]
   s.files = ["tests/popen4_test.rb", "lib/popen4.rb", "CHANGES",  
"ext", "lib", "LICENSE", "pkg", "Rakefile", "rdoc", "README", "tests"]
   s.add_dependency(%q<Platform>, [">= 0.4.0"])
   s.add_dependency(%q<open4>, [">= 0.4.0"])
end
WARNING:  Invalid .gemspec format in '/opt/local/lib/ruby/gems/1.8/ 
specifications/POpen4-0.1.1-unix.gemspec'
rake (0.7.99.3, 0.7.3.1, 0.7.3)
$

-- 
-- Jim Weirich
-- jim.weirich at gmail.com






More information about the Rubygems-developers mailing list